Back to overview
Resolved

All working

Oct 2, 2024 at 9:08am UTC
Affected services
Salty Website
Salty Suite Website
Minecraft Classic Multiplayer Server

Resolved
Oct 2, 2024 at 9:08am UTC

All services online